Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 30, 2024 - 18:00 MDT
Scheduled
We will perform routine maintenance on our production environment to deploy application updates that include bug fixes and feature enhancements. The updates will begin at 6:00 p.m. Mountain time. We will post a notification when the work is completed.
Posted Jul 30, 2024 - 07:00 MDT
This scheduled maintenance affected: Advise, Coach, Communicate, Content Browser, Custom Content Manager (CCM), EMR Modules, and Knowledgebase.